
 

Basic Excel Interview Questions 
Excel is a fundamental tool in the professional world, and many companies test candidates on 
their basic understanding of it during interviews. Whether you’re a fresher or looking to 
strengthen your foundational skills, mastering basic Excel concepts is essential. Here, we’ve 
compiled 20 essential basic Excel interview questions to help you prepare confidently.  
Preparing these Excel interview questions for freshers will give you an edge in securing your 
next job. 

What is a cell in Excel? 
A cell is the intersection of a row and a column in Excel. It's the basic unit where you enter data, 
formulas, or functions. Each cell has a unique address formed by combining the column letter 
and row number (like A1, B2, etc.). 

What is the difference between a workbook and a worksheet? 
A workbook is the entire Excel file with the .xlsx extension. A worksheet is a single sheet within 
a workbook. A workbook can contain multiple worksheets, which appear as tabs at the bottom 
of the Excel window. 

How do you freeze panes in Excel? 
To freeze panes, select the cell below and to the right of where you want to freeze, then go to 
the View tab and click on "Freeze Panes." This keeps specific rows or columns visible while 
scrolling through large datasets. 

What is the shortcut to select an entire row or column? 
To select an entire row, press Shift + Space. To select a whole column, press Ctrl + Space. 

What is the purpose of the SUM function? 
The SUM function adds all the numbers in a selected range of cells. For example, 
=SUM(A1:A10) adds all values from cell A1 to A10. 

How do you create a simple chart in Excel? 
Select the data range, go to the Insert tab, and choose the desired chart type from the Charts 
group. Excel will create a chart based on your selected data. 

What is AutoFill in Excel? 
AutoFill allows you to fill cells with data that follows a pattern quickly. You can drag the fill handle 
(the small square in the bottom-right corner of a selected cell) to extend a series of numbers, 
dates, or custom lists. 



 

What is the difference between relative and absolute cell references? 
Relative references (A1) change when copied to a new location. Absolute references (A$1) 
remain constant when copied. Mixed references (A1 or A$1) fix the column or row. 

How do you merge cells in Excel? 
Select the cells you want to merge, then go to the Home tab and click "Merge & Center" in the 
Alignment group. This combines multiple cells into one larger cell. 

What is the MAX function used for? 
The MAX function returns the largest value in a selected range of cells. For example, 
=MAX(B1:B10) returns the highest number in the range B1 to B10. 

How do you insert a new row or column? 
To insert a row, right-click on the row number where you want to insert and select "Insert." 
Right-click on the column letter for a column and select "Insert." 

What is conditional formatting? 
Conditional formatting changes the appearance of cells based on conditions you specify. It helps 
highlight essential data, identify trends, or visualize data using color scales, data bars, or icon 
sets. 

How do you sort data in Excel? 
Select the data range, go to the Data tab, and click "Sort." You can sort by multiple columns and 
specify ascending or descending order. 

What is the AVERAGE function? 
The AVERAGE function calculates the arithmetic mean of numbers in a selected range. For 
example, =AVERAGE(C1:C10) returns the average values in cells C1 through C10. 

How do you change the number format in Excel? 
Select the cells, right-click, choose "Format Cells," or use the Number group on the Home tab to 
select formats like Currency, Percentage, Date, etc. 

What is the COUNT function? 
The COUNT function counts cells that contain numbers in a selected range. For example, 
=COUNT(A1:A10) counts how many cells in the range A1:A10 contain numeric values. 



 

How do you add comments to cells? 
Right-click on a cell, select "Insert Comment," and type your comment. Cells with comments 
show a red triangle in the upper-right corner. 

What is the IF function used for? 
The IF function performs a logical test and returns one value if the condition is TRUE and 
another value if FALSE. Syntax: =IF(logical_test, value_if_true, value_if_false) 

How do you print a specific area of a worksheet? 
Select the range you want to print, go to the Page Layout tab, click "Print Area," and select "Set 
Print Area." 

What is the difference between the Cut and Copy commands? 
Cut (Ctrl+X) removes the selected data from its original location and places it on the clipboard. 
Copy (Ctrl+C) duplicates the selected data to the clipboard while leaving the original intact. 

Intermediate Excel Interview Questions for Freshers 
Once you’ve mastered the basics of Excel, the next step is to build your knowledge with 
intermediate-level concepts. Many companies evaluate candidates on data handling, pivot 
tables, and logical functions during Excel-based interviews. This section lists 20 carefully 
selected Excel interview questions to help you enhance your skills.  
These Excel interview questions for freshers focus on areas like VLOOKUP, IF statements, data 
validation, and conditional formatting, which are critical for effectively handling day-to-day data 
analysis tasks. 

What are Excel Tables, and how do they differ from regular ranges? 
Excel Tables (created via Insert > Table) are structured ranges with enhanced functionality, 
including automatic formatting, header rows, calculated columns, and dynamic range 
expansion. They automatically update formulas when new data is added, unlike regular ranges. 

Explain the VLOOKUP function and its limitations. 
VLOOKUP searches for a value in the leftmost column of a table and returns a value from a 
specified column in the same row. Syntax: =VLOOKUP(lookup_value, table_array, 
col_index_num, [range_lookup]) 
Limitations include: 

●​ It can only look to the right of the lookup column 
●​ It cannot look up values from right to left 
●​ It's sensitive to column insertion/deletion in the table array 
●​ The first argument must be in the leftmost column of the table array 



 

What is the difference between VLOOKUP and HLOOKUP? 
VLOOKUP searches vertically (down columns), while HLOOKUP searches horizontally (across 
rows). HLOOKUP is used when your lookup values are in the top row of a table. 

How do you use nested IF functions? 
Nested IF functions allow for multiple conditions within a single formula. Example: 
=IF(A1>90,"A",IF(A1>80,"B",IF(A1>70,"C",IF(A1>60,"D","F")))) 
This assigns letter grades based on numeric scores. 

What is the CONCATENATE function, and how can you combine text and 
cell values? 
CONCATENATE (or the newer CONCAT function) joins two or more text strings into one string. 
Example: 
Copy=CONCATENATE("Hello ", A1, "! Today is ", TEXT(TODAY(),"dd-mm-yyyy")) 
You can also use the & operator: ="Hello "&A1&"! Today is "&TEXT(TODAY(),"dd-mm-yyyy") 

How do you create and use Named Ranges? 
Named Ranges assign names to cell references or ranges. To create one: 

●​ Select the range 
●​ Click in the Name Box (left of formula bar) 
●​ Type a name and press Enter 

You can then use this name in formulas instead of cell references, making formulas more 
readable. 

What is a Pivot Table, and when would you use one? 
A Pivot Table is an interactive summary tool that extracts, organizes, and summarizes data. 
You'd use Pivot Tables to analyze large datasets, find patterns, calculate subtotals, create 
cross-tabulations, or generate summary reports. 

Explain the INDEX and MATCH functions and how they can replace 
VLOOKUP. 

●​ INDEX returns a value from a range based on row and column numbers: 
Copy=INDEX(array, row_num, [column_num]) 

●​ MATCH returns the position of a value within a range: 
Copy=MATCH(lookup_value, lookup_array, [match_type]) 

●​ Combined, they create a powerful lookup: 
Copy=INDEX(return_range, MATCH(lookup_value, lookup_column, 0)) 
Advantages over VLOOKUP: 

●​ Can look in any direction (not just right) 
●​ More flexible and faster for large datasets 



 

●​ Column insertions/deletions don't break the formula 

What are array formulas, and when would you use them? 
Array formulas perform multiple calculations on one or more items in an array. They're used for 
complex calculations that can't be done with standard formulas. In newer Excel versions, they're 
created with dynamic array functions. In older versions, they required Ctrl+Shift+Enter. 

How do you remove duplicates from data? 
Select your data range, go to Data tab > Data Tools group > Remove Duplicates. Select the 
columns to check for duplicates and click OK. 

What is Goal See,k and how is it useful? 
Goal Seek is a what-if analysis tool that finds an input value needed to achieve a desired result. 
It's useful when you know the desired outcome but must determine the required input value. 

How do you create and use Data Validation? 
Data Validation restricts the type of data that can be entered in a cell: 

●​ Select the cells 
●​ Go to Data tab > Data Tools group > Data Validation 
●​ Set your validation criteria (like lists, date ranges, or custom formulas) 

It helps create drop-down lists and prevent incorrect data entry. 

What is the SUMIF function, and how does it differ from SUMIFS? 
●​ SUMIF adds values that meet a single condition: 

Copy=SUMIF(range, criteria, [sum_range]) 
●​ SUMIFS allows multiple conditions: 

Copy=SUMIFS(sum_range, criteria_range1, criteria1, [criteria_range2, criteria2]...) 

How do you create a dynamic chart that automatically updates with new 
data? 

●​ Format your data as an Excel Table 
●​ Create a chart based on this table 
●​ As you add data to the table, the chart will automatically update 

What is Flash Fill, and how does it work? 
Flash Fill (available since Excel 2013) automatically recognizes patterns in your data entry and 
completes the pattern. Type a few examples of the pattern you want, and Excel suggests 
completing the rest. Press Enter to accept. 



 

Explain the COUNTIF and COUNTIFS functions. 
●​ COUNTIF counts cells that meet a single condition: 

Copy=COUNTIF(range, criteria) 
●​ COUNTIFS counts cells that meet multiple conditions: 

Copy=COUNTIFS(criteria_range1, criteria1, [criteria_range2, criteria2]...) 

How do you create a formula that references another worksheet? 
●​ Use the sheet name followed by an exclamation mark before the cell reference: 

Copy=Sheet2!A1 
●​ For sheet names with spaces: 

Copy='Sales Data'!A1 

What are Excel's Text functions? Give examples. 
Excel has several text manipulation functions: 

●​ LEFT(text, num_chars): Returns leftmost characters 
●​ RIGHT(text, num_chars): Returns rightmost characters 
●​ MID(text, start_num, num_chars): Returns characters from the middle 
●​ TRIM(text): Removes extra spaces 
●​ PROPER(text): Capitalizes first letter of each word 
●​ UPPER(text): Converts to uppercase 
●​ LOWER(text): Converts to lowercase 

How do you use the SUBSTITUTE function? 
●​ SUBSTITUTE replaces specific text within a string: 

Copy=SUBSTITUTE(text, old_text, new_text, [instance_num]) 
●​ Example: =SUBSTITUTE("Excel is great", "great", "amazing") returns "Excel is amazing" 

What is the purpose of the IFERROR function? 
IFERROR catches and handles formula errors by returning an alternative value when an error 
occurs: 
Copy=IFERROR(value, value_if_error) 
Example: =IFERROR(A1/B1, "Division by zero") returns "Division by zero" if B1 contains 0. 

Advanced Excel Interview Questions 
Advanced Excel skills are highly valued in data-driven roles, where complex data analysis and 
automation are key. Candidates applying for analyst, finance, and operations roles often face 
challenging Excel-related questions in their interviews.  
This section presents 20 advanced Excel interview questions to test your knowledge of macros, 
data analysis tools, advanced formulas, and automation.  



 

Explain how the INDIRECT function works with an example. 
The INDIRECT function converts a text string into a valid cell reference: 
Copy=INDIRECT(ref_text, [a1]) 
Example: If A1 contains "B5", then =INDIRECT(A1) returns the value from cell B5. This allows 
for dynamic referencing based on cell contents. 

How do you use Excel's Data Model for PowerPivot? 
Excel's Data Model allows you to: 

●​ Import data from multiple sources 
●​ Create relationships between tables 
●​ Build complex calculations using DAX (Data Analysis Expressions) 
●​ Create PivotTables from multiple related tables 
●​ Access it through PowerPivot in the Data tab (requires enabling in some Excel versions). 

What are the Power Query and Get & Transform features? 
Power Query (Get & Transform in newer versions) is an ETL tool that allows you to: 

●​ Connect to various data sources 
●​ Transform and clean data with a graphical interface 
●​ Load results into Excel or the Data Model 
●​ Create reusable, refreshable data connections 

How would you perform regression analysis in Excel? 
●​ Use the Data Analysis Toolpak (enable in Excel Options > Add-ins) 
●​ Select Data > Data Analysis > Regression 
●​ Input your Y and X ranges 
●​ Configure output options 
●​ Analyze the regression statistics, including R-squared, coefficients, and p-values 

Explain DAX (Data Analysis Expressions) and its use in Excel. 
DAX is a formula language used in PowerPivot and the Excel Data Model to create custom 
calculations in tables and relationships. It extends Excel's functionality with time intelligence, 
complex filtering, and aggregation functions. 

What are Slicers and Timeline controls? 
Slicers are visual filters that allow users to filter PivotTable data by clicking buttons. Timeline 
controls are specialized slicers for date fields that let users filter by periods (days, months, 
quarters, years). 

How do you create a forecast sheet in Excel? 
●​ Select your time series data (dates and values) 



 

●​ Go to Data tab > Forecast group > Forecast Sheet 
●​ Configure forecast options (end date, confidence interval, seasonality) 
●​ Excel creates a new sheet with forecasted values and a chart 

What are structured references in Excel Tables? 
Structured references allow you to refer to Excel Table elements by name rather than cell 
references: 

●​ TableName[ColumnName]: References an entire column 
●​ TableName[@ColumnName]: References the current row's value 
●​ TableName[#Headers]: References the header row 
●​ Example: =SUM(Sales[Quantity]*Sales[Price]) 

Explain the SUMPRODUCT function with an example. 
SUMPRODUCT multiplies corresponding elements in arrays and returns the sum of those 
products: 

●​ Copy=SUMPRODUCT(array1, [array2], ...) 
●​ Example: =SUMPRODUCT(B2:B10, C2:C10) multiplies each value in B2:B10 with the 

corresponding value in C2:C10, then adds these products. 

How do you create and use Data Tables for sensitivity analysis? 
Data Tables are what-if analysis tools for testing different input values: 

●​ Set up your model with formulas 
●​ Create a data table layout (row inputs, column inputs, or both) 
●​ Select the table range 
●​ Go to Data > What-If Analysis > Data Table 
●​ Enter input cell references 

What is Power View in Excel, and how is it used? 
Power View is an interactive data visualization tool in Excel that creates dashboards and 
reports. It allows you to create multiple visualizations (charts, maps, tables) on a single sheet. 
(Note: Available in older versions but being phased out in favor of Power BI.) 

How do you protect specific cells in a worksheet while allowing others to be 
edited? 

●​ Unlock the cells you want users to edit (Format Cells > Protection > uncheck "Locked") 
●​ Protect the worksheet (Review tab > Protect Sheet) 
●​ Optionally set a password and select allowed actions 
●​ By default, all cells are locked, but protection is not enabled. 



 

What are the different lookup functions in Excel? 
Excel offers several lookup functions: 

●​ VLOOKUP: Searches vertically for a value in the leftmost column and returns a value 
from the specified column 

●​ HLOOKUP: Searches horizontally for a value in the top row and returns a value from the 
specified row 

●​ INDEX/MATCH: A powerful combination for flexible lookups in any direction 
●​ XLOOKUP (newer versions): A versatile function that combines VLOOKUP, HLOOKUP, 

and INDEX/MATCH capabilities 
●​ LOOKUP: Simpler vector and array forms for one-way lookups 
●​ CHOOSE: Returns a value from a list based on position 

How do you use OFFSET and INDIRECT together for dynamic ranges? 
Combining OFFSET and INDIRECT creates powerful dynamic ranges: 
Copy=OFFSET(INDIRECT("Sheet1!A1"),0,0,COUNTA(Sheet1!A:A),1) 
This creates a range starting at A1 that automatically expands to include all non-empty cells in 
column A, useful for charts and named ranges that need to grow with data. 

Explain how to use the XIRR function for irregular cash flows. 
XIRR calculates the internal rate of return for a schedule of cash flows occurring at irregular 
intervals: 
Copy=XIRR(values, dates, [guess]) 

●​ Values: Range containing cash flows (negative for investments, positive for returns) 
●​ dates: Corresponding dates of each cash flow 
●​ guess: Optional estimate of expected IRR 

This is particularly useful for analyzing investments with uneven payment schedules. 

What is the R1C1 reference style in Excel? 
R1C1 is an alternative reference style where numbers refer to both rows and columns: 

●​ R2C3 refers to the cell in row 2, column 3 (equivalent to C2 in A1 style) 
●​ R[-1]C[2] refers to the cell one row up and two columns to the right (relative reference) 
●​ This style is handy in VBA and for creating specific types of dynamic formulas. 

How do you use PowerPivot to create a calculated field with time 
intelligence? 
In Power Pivot: 

●​ Create a Date table with a continuous date range 
●​ Mark it as a Date table using the Calendar function 
●​ Create relationships between the Date table and fact tables 
●​ Use DAX time intelligence functions like SAMEPERIODLASTYEAR: 



 

CopyYOY Growth := SUM(Sales[Amount]) - CALCULATE(SUM(Sales[Amount]), 
SAMEPERIODLASTYEAR('Date'[Date])) 

How do you use the CUBEVALUE function with external data sources? 
CUBEVALUE retrieves data from OLAP data sources: 

●​ Copy=CUBEVALUE(connection, [member_expression1], [member_expression2],...) 
This lets you pull specific measures and dimensions from external multidimensional databases 
like SQL Server Analysis Services. 

Explain array constants and their use in complex formulas. 
Array constants are fixed values enclosed in curly braces that can be used in array formulas: 

●​ Copy=SUM(IF({1,2,3,4,5}=A1:A5,B1:B5,0)) 
This sums values from B1:B5 only where the corresponding A1:A5 values match any number in 
the array {1,2,3,4,5}. 

How do you implement the Monte Carlo simulation in Excel? 
Monte Carlo simulation in Excel involves: 

●​ Define input variables with probability distributions (using RAND() or RANDBETWEEN()) 
●​ Create a calculation model using these inputs 
●​ Set up Data Table or VBA to run multiple iterations 
●​ Collect and analyze the distribution of results 

This technique helps analyze risk and uncertainty in financial models, project management, and 
other applications. 

Excel Tricks and Shortcuts Interview Questions 
Efficiency in Excel is not just about knowing the functions but also about using shortcuts and 
tricks to save time. Many interviewers assess a candidate’s ability to work efficiently under 
pressure using Excel’s hidden tricks and shortcuts. This part covers essential Excel interview 
questions focused on productivity-enhancing shortcuts and lesser-known tricks.  
Preparing these Excel interview questions for freshers will improve your speed and accuracy, 
helping you perform better in Excel-based job tests and day-to-day work scenarios. 

What are some essential keyboard shortcuts for navigating Excel 
efficiently? 

●​ Ctrl+Home: Go to cell A1 
●​ Ctrl+End: Go to last used cell 
●​ Ctrl+Arrow keys: Jump to the edge of data regions 
●​ Alt+Page Down/Up: Move one screen right/left 
●​ Ctrl+G: Open Go To dialog 
●​ F5: Same as Ctrl+G (Go To) 



 

●​ Ctrl+Tab: Switch between open workbooks 

How do you quickly create a chart from selected data? 
Select your data and press Alt+F1 for an instant column chart or F11 for a chart on a new sheet. 
This shortcut helps vto isualize data without navigating through menus. 

What's the fastest way to sum a range of numbers? 
Select the range and look at the status bar (bottom right) for the sum. For more control, select 
the range and press Alt+= to insert a SUM function automatically. 

How do you quickly fill formulas down to match adjacent data? 
Double-click the fill handle (the small square in the bottom-right corner of the selected cell) to 
automatically fill down to match adjacent data without dragging. 

What's the shortcut for inserting the current date or time? 
●​ Ctrl+; (semicolon): Insert current date 
●​ Ctrl+Shift+; (semicolon): Insert current time 

These values are static and won't update automatically. 

How do you quickly format cells as percentages or currency? 
●​ Ctrl+Shift+% for percentage format 
●​ Ctrl+Shift+$ for currency format 
●​ Ctrl+Shift+# for date format 
●​ Ctrl+Shift+@ for time format 

What's the fastest way to create a Pivot Table? 
Select your data range and press Alt+N+V to open the PivotTable wizard. This shortcut helps 
analyze data quickly without navigating through ribbons. 

How do you use Flash Fill to manipulate text data? 
Enter a few examples of the pattern you want, then press Ctrl+E to activate Flash Fill. Excel will 
detect the pattern and complete the remaining cells automatically. 

What is the quickest way to insert or delete rows/columns? 
●​ Ctrl+Shift++ (plus): Insert rows/columns 
●​ Ctrl+- (minus): Delete rows/columns 

First, select entire rows or columns before using these shortcuts. 



 

How can you quickly apply a filter to your data? 
Select any cell within your data and press Ctrl+Shift+L to toggle filters on/off. This adds 
dropdown arrows to your header row for instant filtering. 
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